Subscription preference

Notification emails are sent to your Samsung account email address.

* Email : anonymous@samsung.com

  

Close

Install Stop: List of limitations in Gear Watch Designer?

Forums View
Started by Newbie joyce71h , 140 Seed Dec 17, 2017 18:13 Replies : 11 View : 1028 Likes : 0
I received an error testing my watch face on a Gear S2. (Does work on a Gear S3)
The error is:

----------------------------------------------------------------------------------------
This device doesn't support some features which current watch face contains.
Remote that features and rebuild, or upgrade your device.

- Current watch face version: 2.3.2.3
- Device platform version 2.3.2.2

-----------------------------------------------------------------------------------------

I have already removed new additions to the watchface (steps %) that were added after the last test but that doesn't work.

So I'm having trouble finding the feature that is not supported. Is there a list of features that are only supported on 2.3.2.3?
I have found very few on the forum but none of them are used in this watchface.


Tags

InstallStop

Post Reply
Board View
Samsung Developer s.arefin , 36250 Seed Dec 18, 2017 11:36 Post #1 0
Hi, 
from your description it is version mismatch, please update your device platform or you can design this watch face using lower version of GWD which support yout device platform version. so far my understanding newer versions of GWD may not support lower than 2.3.X.X. 
please check again thanks.
Post Reply
Board View
Samsung Developer drazen , 45520 Seed Dec 18, 2017 11:38 Post #2 0
What GWD are you using? I think there should be a pop-up screen when trying to use for example Weather widgets that lists all features that are available only for newer devices. Also, for example if you use Text and want to create Calorie counter, you will notice that in text properties there's an exclamation mark next to certain functions - if you check that exclamation mark, there will also be a pop-up screen that explains that these features do not work with older devices.
Post Reply
Board View
Newbie marcdek65 , 650 Seed Dec 19, 2017 10:10 Post #3 0


This content has been quoted from s.arefin’s thought.

Hi, 
from your description it is version mismatch, please update your device platform or you can design this watch face using lower version of GWD which support yout device platform version. so far my understanding newer versions of GWD may not support lower than 2.3.X.X. 
please check again thanks.

Thanks for your reply (I posted the original post with the account of my partner, sorry)

The Gear S2 is 3.2.2.2 (which is the latest version for that watch). I have developed a few watchfaces with GWD 1.5.1 that work perfectly on the S2. The design I was working on also worked great. 
After rebuilding it with new hands and adding step counter the watchface worked great on a S3 but the given error was shown when uploading to the S2

Obviously I have removed the step counter (which was the only new addition) but to no avail.

 
Post Reply
Board View
Newbie marcdek65 , 650 Seed Dec 19, 2017 10:12 Post #4 0


This content has been quoted from drazen’s thought.

What GWD are you using? I think there should be a pop-up screen when trying to use for example Weather widgets that lists all features that are available only for newer devices. Also, for example if you use Text and want to create Calorie counter, you will notice that in text properties there’s an exclamation mark next to certain functions - if you check that exclamation mark, there will also be a pop-up screen that explains that these features do not work with older devices.

I am using 1.5.1. The pop up never came when adding the step counter and also removing the step counter does not solve the problem.

So I am seeking a list of functions that are not working on the S2 because I cannot find the part of the watch that causes the problem.
Post Reply
Board View
r.liechty , Dec 19, 2017 16:08 Post #5 0


This content has been quoted from marcdek65’s thought.

 



This content has been quoted from drazen’s thought.

What GWD are you using? I think there should be a pop-up screen when trying to use for example Weather widgets that lists all features that are available only for newer devices. Also, for example if you use Text and want to create Calorie counter, you will notice that in text properties there’s an exclamation mark next to certain functions - if you check that exclamation mark, there will also be a pop-up screen that explains that these features do not work with older devices.

I am using 1.5.1. The pop up never came when adding the step counter and also removing the step counter does not solve the problem.

So I am seeking a list of functions that are not working on the S2 because I cannot find the part of the watch that causes the problem.

 

If you do discover what feature it is and there is not warning,  please let us know so I can report it as a bug.

You can downloadan older version of GWD from here 
Just click the down arrow and all the previous versions are available for download. Remember the file paths are different from 1.4.x to 1.5.x so you would need to create a new project if you go back to 1.4.x

I think everyone else has suggested anything I can think of.

Ron

Post Reply
Board View
Newbie marcdek65 , 650 Seed Dec 20, 2017 11:52 Post #6 0


This content has been quoted from r.liechty’s thought.

 



This content has been quoted from marcdek65’s thought.

 



This content has been quoted from drazen’s thought.

What GWD are you using? I think there should be a pop-up screen when trying to use for example Weather widgets that lists all features that are available only for newer devices. Also, for example if you use Text and want to create Calorie counter, you will notice that in text properties there’s an exclamation mark next to certain functions - if you check that exclamation mark, there will also be a pop-up screen that explains that these features do not work with older devices.

I am using 1.5.1. The pop up never came when adding the step counter and also removing the step counter does not solve the problem.

So I am seeking a list of functions that are not working on the S2 because I cannot find the part of the watch that causes the problem.

 

If you do discover what feature it is and there is not warning,  please let us know so I can report it as a bug.

You can downloadan older version of GWD from here 
Just click the down arrow and all the previous versions are available for download. Remember the file paths are different from 1.4.x to 1.5.x so you would need to create a new project if you go back to 1.4.x

I think everyone else has suggested anything I can think of.

Ron

 

So I'm afraid there is no list of compatible functions then.
There should be, because if the software knows that a particular function does not work on 2.3.2.2 then the developers also need to know.
@Samsung: anybody?
Post Reply
Board View
r.liechty , Dec 20, 2017 16:12 Post #7 0
< So I'm afraid there is no list of compatible functions then.
There should be, because if the software knows that a particular function does not work on 2.3.2.2 then the developers also need to know.
@Samsung: anybody? >

I'lll keep looking for you.  The Developer Team should have a full list but if they aren't giving you an error then it is a bug, That is why I asked if you found what it was to let me know.

Ron


Post Reply
Board View
Newbie marcdek65 , 650 Seed Dec 21, 2017 14:01 Post #8 0


This content has been quoted from r.liechty’s thought.

< So I’m afraid there is no list of compatible functions then.
There should be, because if the software knows that a particular function does not work on 2.3.2.2 then the developers also need to know.
@Samsung: anybody? >

I’lll keep looking for you.  The Developer Team should have a full list but if they aren’t giving you an error then it is a bug, That is why I asked if you found what it was to let me know.

Ron

 

 have not. But I have not been trying again. I have been removing newly added items but this did not work.
Maybe it's a suggestion that if the software checks the design and finds an incompatilble function that it states this function instead of 'a' function.
Post Reply
Board View
r.liechty , Dec 26, 2017 17:55 Post #9 0
My apology for the delay in replying. I did contact the developer team and got some information.


I guess that developer add other features which rquires Tizen 2.3.2.3 or later.

When developers add features on their watch face, they can esaily see if that feature is supported on specific device As mentioned before the information icon should tell you what is incompatible. Step count does not cause this version mismatch problem.

They had two possible problems. 

Floor (TEXT, Hand, Set as button), Set as button > Double tap > Open app is related to this restriction.

Also, if you made AOD watch faces there are some features restricted on specific version are AOD watch faces

I hope this helps.

Ron


Post Reply
Board View
r.liechty , Dec 27, 2017 02:59 Post #10 0
More Information for a solution

The watchface platform version will become 2.3.2.3 only when one of following feature is enabled.

1.     ‘In App Purchase’ setting is enabled.

2.     ‘App Switcher’ is used in the button action.

3.     Multiple languages are selected in the language setting dialog.

Ron
 
Post Reply
Board View
Newbie marcdek65 , 650 Seed Jan 02, 2018 13:02 Post #11 0


This content has been quoted from r.liechty’s thought.

More Information for a solution

The watchface platform version will become 2.3.2.3 only when one of following feature is enabled.

1.     ‘In App Purchase’ setting is enabled.

2.     ‘App Switcher’ is used in the button action.

3.     Multiple languages are selected in the language setting dialog.

Ron
 

I have been playing with multiple language settings. But after the error I have removed the second language. Possibly the software does nog recognize the change back.
I will try to remove the date display and add a new one with only one language. I'll let you know. 
Post Reply