Subscription preference

Notification emails are sent to your Samsung account email address.

* Email : anonymous@samsung.com

  

Close

Can't connect to GWD after Tizen v3.0.0.1 (R760XXU2CQL1) Update

Forums View
Started by Newbie stephenvajda , 520 Seed Dec 19, 2017 18:20 Replies : 5 View : 735 Likes : 0
Lost my Gear S3 custom watch faces after installing R760XXU2CQL1. I reset the watch and established a new connection to my phone. I tried to restore a back up, but that seemed to do nothing?!? I manually reconfigured my settings, but now GWD v 1.5.1 does not find the Gear S3.

Gear S3
Settings > Connections > Wi-Fi > Wi-Fi = Always on (Verified Connection Status and IP address)
Settings > About Gear > Debugging = Enabled

GWD
Run on Device
Scan devices fails.
Add device - Input device IP address to connect also fails.

This is very frustrating! Any help is greatly appreciated.
Post Reply
Board View
Samsung Developer drazen , 45520 Seed Dec 20, 2017 15:18 Post #1 0
Turn Bluetooth to OFF, keep the screen on smartwatch on, also try opening some app on watch that needs internet connection and try updating it - forcing the watch to use the wifi for data transfer. I usually use Weather. Once that is done, open GWD and try again. Do not open GWD first!
Post Reply
Board View
r.liechty , Dec 20, 2017 16:04 Post #2 0
Because of caching and file changes under Tizen update, under the conditions below a watch face will have a probelm on Tizen 3.0

1. A watch face made by GWD v1.4.1 or older (let say WatchA)
2. WatchA is installed in Gear Tizen v2.3.2.x or older
3. That Gear device is updated to Tizen 3.0
4. Then WatchA may not operate and be unable to remove .

To prevent this problem 
1. Remove WatchA before Tizen 3.0 update
2. Update your Gear to Tizen 3.0
3. Rebuild WatchA with GWD 1.5,0 or later version.
4. Install WatchA to Gear Tizen 3.0 device.

if you alreay update your Gear S3 to Tizen 3.0 and some watches have problem with this issue, 
there is no way to fiix it. You need to reset your Gear.

If you got the watch face by7 Store download, it should be OK.

Ron
Post Reply
Board View
Newbie stephenvajda , 520 Seed Dec 20, 2017 17:13 Post #3 0


This content has been quoted from drazen’s thought.

Turn Bluetooth to OFF, keep the screen on smartwatch on, also try opening some app on watch that needs internet connection and try updating it - forcing the watch to use the wifi for data transfer. I usually use Weather. Once that is done, open GWD and try again. Do not open GWD first!

Thanks for the suggestion, but that didn't work.
I also tried the following: 
Reset the Gear S3 and initialized without connecting to my phone and connected the Gear S3 to Wi-Fi.
Tried a different Wi-Fi router.
Installed older version of GWD on a different computer.

Anyone know of another way to install a custom watchface?
Post Reply
Board View
Samsung Developer drazen , 45520 Seed Dec 20, 2017 22:59 Post #4 0


This content has been quoted from stephenvajda’s thought.

 

Thanks for the suggestion, but that didn’t work.
I also tried the following: 
Reset the Gear S3 and initialized without connecting to my phone and connected the Gear S3 to Wi-Fi.
Tried a different Wi-Fi router.
Installed older version of GWD on a different computer.

Anyone know of another way to install a custom watchface?

 

That's a bummer. I see you're not new to routers and networking, but maybe as a last thing that comes to my mind - does the computer have firewall or anti-virus software enabled? Perhaps that's what's blocking the smartwatch... 

I had a lot of issues like you with my old router. Then I finally gave up, went to the store and bought a 150$ Dlink router. All my connection issues magically disappeared. I now get a positive connection on first attempt, it works even through VPN (with my computer and GWD showing a different IP address than the one on the smartwatch). Not saying you should run to the store with your credit card in hand, but that was my experience.

Speaking of alternative solutions, if I'm not mistaken Samsung has also added a wired solution for GWD connections. You need to have your smartphone attached to the computer with the cable and watch connected to the smartphone obviously via bluetooth. You can read more here: http://developer.samsung.com/gear/design/watch-designer/gear-watch-getting/connect

Post Reply
Board View
Developer malcolmpe , 9350 Seed Dec 22, 2017 00:06 Post #5 0


This content has been quoted from drazen’s thought.

 



This content has been quoted from stephenvajda’s thought.

 

Thanks for the suggestion, but that didn’t work.
I also tried the following: 
Reset the Gear S3 and initialized without connecting to my phone and connected the Gear S3 to Wi-Fi.
Tried a different Wi-Fi router.
Installed older version of GWD on a different computer.

Anyone know of another way to install a custom watchface?

 

That’s a bummer. I see you’re not new to routers and networking, but maybe as a last thing that comes to my mind - does the computer have firewall or anti-virus software enabled? Perhaps that’s what’s blocking the smartwatch... 

I had a lot of issues like you with my old router. Then I finally gave up, went to the store and bought a 150$ Dlink router. All my connection issues magically disappeared. I now get a positive connection on first attempt, it works even through VPN (with my computer and GWD showing a different IP address than the one on the smartwatch). Not saying you should run to the store with your credit card in hand, but that was my experience.

Speaking of alternative solutions, if I’m not mistaken Samsung has also added a wired solution for GWD connections. You need to have your smartphone attached to the computer with the cable and watch connected to the smartphone obviously via bluetooth. You can read more here: http://developer.samsung.com/gear/design/watch-designer/gear-watch-getting/connect

 

After resetting the watch to factory setting go to the network settings, then to your network you are conncted it to., scroll down for the IP address it should  go as follows 192.168.1._ the last number/ digit identifies the watch on your network. In the GWD program open the face you have created , click on the watch icon , it will say it is searching click the + sign and input the  ip address from your watch and it should connect. Remember when you reset your watch, the router sometimes assigns a new ip address (Please Follow all this after putting debugging ON  in the watch settings) My guess is you might be putting the old ip address which might be changed by the router.
Give it a shot. Good luck
Also in your router settings check if your computer and watch are on the same bandwi and if both are connected on the the same network 2.4mhz or 5.0 mhz
Post Reply