Development Environment

Check prerequisites first and follow all steps below to create a Samsung Health's partner app.

Prerequisites

Check following prerequisites before downloading Samsung Health SDK.

Android Version

Android 4.4 KitKat (API Level 19) or above.

Available Devices

Android smartphones including non-Samsung devices.

Samsung Health Version

Samsung Health's partner app runs with Samsung Health 4.0 or above.

Downloading Samsung Health SDK

Samsung Health SDK can be downloaded on the Samsung developer site. You can find the following content in the SDK's Health Service.

Folder in SDK Description
Docs
  • API Reference
    Describes the SDK's Health Service APIs.
  • Programming Guide
    Contains development information to create a Samsung Health's partner app with Health Service.
  • Tracker Design Guidelines
    Guidelines for designing the app's tracker and tracker tile to add to Samsung Health.
Libs
  • samsung-health-service-va.b.c.jar
    Health Service library of Samsung Health SDK.
  • sdk-v1.0.0.jar
    Samsung SDK basic library.
Samples
  • PluginTracker
    Sample app created by using the Health Service library. This app posts its sample tracker tile to Samsung Health and launches a specific Samsung Health's tracker.
Table 3: Samsung Health SDK's Health Service content