top

Prerequisites for the TV Extension

 

 

Pre-setting requirements

Java

The Samsung Smart TV SDK 2.0 Eclipse plugin requires Java Standard Edition (Java SE) version 1.7 or higher. Please install the Java SE Development Kit (JDK):
http://www.oracle.com/technetwork/java/javase/downloads/index.html

CPU specification

If you use Samsung Smart TV Emulator, VT(Virtualization Technology) should be supported by the CPU.

  • Windows & Mac OS : Intel VTx should be supported by the CPU. (For Haxm)

  • Linux : Intel VT-x or AMD-V™ should be supported by the CPU. (For KVM)

On Ubuntu®

NVIDIA®/ATI® driver for Ubuntu® 12.04/14.04 : To upgrade, go to System Settings > Additional Drivers. Download the latest driver from the vendor site, and install it.
INTEL® driver for Ubuntu® 12.04/14.04 : Requires an Intel® driver version 8.0.1 or higher. Ubuntu® 12.04 supports an Intel® driver higher than 8.0.1.

On Windows®

Depending on your OS theme (such as non-Aero themes and Windows XP themes), a display surface can be erased for a while if the Emulator window is obscured by another window. If you click the Emulator window, the display surface works correctly again.

If the host machine is using the Nvidia Optimus™ technology, the TV Emulator works with the on-board graphics chipset, and not with the Nvidia® external graphics card. To prevent this, you can ether disable the Nvidia Optimus™ technology, or set the TV Emulator to run with the Nvidia® external graphics card.

 

System Requirements

Processor : Dual Core 2.8GHz / Single Core 3GHz or higher

  • VT(Virtualization Technology) should be supported by the CPU (For TV Emulator)

    • Windows & Mac OS : Intel VTx should be supported by the CPU. (HAXM)

    • Linux : Intel VT-x or AMD-V™ should be supported by the CPU. (KVM)

    • HAXM :Intel HAXM requires an Intel processor with Intel VT-x functionality and cannot be used on systems lacking this hardware feature. To determine the capabilities of your Intel processor, visit http://ark.intel.com/.

    • KVM :To determine the information of CPUs which support Hardware virtualization of KVM, visit http://www.linux-kvm.org/page/Processor_support.

RAM : 4 GB or higher

OS (32bit and 64bit supported) :

  • Windows 7 (64bit recommendation), Windows XP Service Pack 2 or higher

  • Linux : Tested on Ubuntu 12.x

  • Mac OS X : Intel-based hardware, OS versions 10.6 and above. Apple Mac OS X 10.8(Mountain Lion) 64-bit, 10.9(Mavericks) 64-bit.

Screen resolution : 1280 x 1024 or higher

HDD :5GB or higher. When the disk storage is full, various incorrect operations can occur.