Subscription preference

Notification emails are sent to your Samsung account email address.

* Email : anonymous@samsung.com

  

Close

Gear Watch Designer won't start and there is no error message

Forums View
Started by Developer galaxys4 , 1390 Seed Feb 28, 2018 09:44 Replies : 5 View : 927 Likes : 0
I installed 1.5.2 and it won't start. I have both 32 bit and 64 bit java installed. Both are Version 8 Update 161. I tried adding the line in FAQ #20 to the ini file, both the 32 bit and the 64 bit separately. I uninstalled and reinstalled. I rebooted WIndows after installing. I'm running Windows 7 Pro 64 bit. I look in the Task Manager and I don't see any thread starting and closing but maybe it's too fast for me to observe. If I put the line in as shown in FAQ #20 as two lines instead of on a single line then I do get an error message. "Java was started but returned exit code=13". See attached image. How can I get this to work? Thanks.
Post Reply
Board View
r.liechty , Feb 28, 2018 17:24 Post #1 0
Did you have the 1.5.1 version of Gear Watch Designer installed and did it work or is this the first for Gear Watch Designer?

Some things to check if this is the first time for Gear Watch Designer since it is a Java app.

You should only have one version of Java that may be the problem. You can see if you have a 32 bit or 64 bit system from File Manager right click on My PC and then click on Properties.

In the command prompt type 
Java -version 
and see what comes up.  If it isn't listed then your path isn't set.

I usually install the JDK with netbeans (which also has the JRE) from Oracle as that sets the path and enviromental variables correctly.
GET IT HERE

Another user had a similar problem because GWD was not installed in C drive.

Are you running as the same user that you installed GWD under?  If not you may need to uninstall it and reinstall it from that user account.

Let me know if none of this works.

Ron
Samsung Developer Program
Post Reply
Board View
Developer galaxys4 , 1390 Seed Mar 01, 2018 01:06 Post #2 0


This content has been quoted from r.liechty’s thought.

Did you have the 1.5.1 version of Gear Watch Designer installed and did it work or is this the first for Gear Watch Designer?

Some things to check if this is the first time for Gear Watch Designer since it is a Java app.

You should only have one version of Java that may be the problem. You can see if you have a 32 bit or 64 bit system from File Manager right click on My PC and then click on Properties.

In the command prompt type 
Java -version 
and see what comes up.  If it isn’t listed then your path isn’t set.

I usually install the JDK with netbeans (which also has the JRE) from Oracle as that sets the path and enviromental variables correctly.
GET IT HERE

Another user had a similar problem because GWD was not installed in C drive.

Are you running as the same user that you installed GWD under?  If not you may need to uninstall it and reinstall it from that user account.

Let me know if none of this works.

Ron
Samsung Developer Program


Hi Ron,

I had downloaded 1.5.0 but I'm not sure I ever installed it. I tried yesterday and it didn't run so I checked and downloaded the latest, 1.5.2. I installed it under my own user. I am the only user that uses this PC. Java is installed on the C drive. I use another Java program called DirSyncPro and it works okay.

The About Java dialog tells me I have version 8 Update 161 (build 1.8.0_161_b12).

The Java Runtime Environment Settings dialog tells me I have the 32 bit version and the 54 bit version both in their respective Program FIles folder. Both are enabled.

The command you asked me to type says:

java version "1.8.0_161"
Java(TM) SE Runtime Environment (build 1.8.0_161-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.161-b12, mixed mode)

When I follow FAQ 20 and add to the ini file the lines:

-vm
C:\Program Files\Java\jre1.8.0_161\bin\javaw.exe

I get exit code 13. When I use the (x86) Program Files instead, I get exit code 1. I did see somewhere the Gear Watch Designer needs the 32 bit version. I tried disabling the 64 bit version and I still get the error.

When I put in the ini file:

-vm C:\Program Files\Java\jre1.8.0_161\bin\javaw.exe

or 

-vm C:\Program Files (x86)\Java\jre1.8.0_161\bin\javaw.exe

or if I remove that line, I still get the program not opening at all or at least not showing anything

I don't see the image I uploaded. I'll try again here.

I will try to uninstall both GWD and Java and reinstall Java with the link uyou provided and reply again later.

Thanks,

Bill
 

File Attachments
Post Reply
Board View
r.liechty , Mar 01, 2018 17:30 Post #3 0
Hi,

Install the Netbeans and JDK 8 http://www.oracle.com/technetwork/articles/javase/jdk-netbeans-jsp-142931.html from Oracle  I used the 64bit version. That pretty much solves any Java issues on Windows.

I have build 151 not 161.

java version "1.8.0_151"
Java(TM) SE Runtime Environment (build 1.8.0_151-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.151-b12, mixed mode) 

However I installed Java 9 on another computer and GWD 1.5.2 installed and runs fine on that. 

Ron
Post Reply
Board View
r.liechty , Mar 01, 2018 17:41 Post #4 0

Also  there was an issue with Windows 7 hanging on save in some versions.  This should be fixed in GWD 1.5.2 but if it isn't let me know.  The work around is to hit esc several times.

Ron



Post Reply
Board View
Developer galaxys4 , 1390 Seed Mar 05, 2018 10:17 Post #5 0
I uninstalled both 32 bit and 64 bit Java. I installed the 64 bit version recommended that includes Net Beans. Didn't open but gave an error. I then installed 32 bit with Net Beans. So now both 32 and 64 bit versions are installed.

Now I can open the program. Thanks.
Post Reply