Subscription preference

Notification emails are sent to your Samsung account email address.

* Email : anonymous@samsung.com

  

Close

Galaxy S9+ GPU/Renderscript error

Forums View
Started by Newbie stelian.morari**** , 320 Seed Apr 03, 2018 16:42 Replies : 2 View : 1300 Likes : 0
I'm working with the Camera2 API and I'm using Renderscript to perform some image processing. Everything works as expected on a range 
of devices(Nexus 5/5x, Pixel, Pixel 2, S8+, Note 8) except for the S9+. 

 
 
Basically what I'm doing is creating an `Allocation` to receive camera data and another `Allocation` that will use the camera data, apply a transformation and the display the result on a `Surface` which will act as the camera preview. 
On the S9+ I get a black screen (no preview) and LogCat shows the following error: 
 
I managed to track down the error to a native library loading issue:



 
This is only happening on the S9, the other Samsung devices work without any issues.
 
The S8+ is on Android Nougat(24) and the S9+ is on Oreo(26), both have OpenGL ES 3.2.
 
Does anyone have any idea on how to fix this?
 
PS: tested on other devices running Oreo without any issues  
 
I updated the S9+ to the latest version (R16NW.G965FXXU1ARCC) but the issue still remains.
 
Also, based on comment suggestion, I checked the /vendor/lib64 folder to check if the libbccArm and libccc are present, but only one of them is present:
 
 
 
I actually found libbcc.so in the /System/system/lib64 but the S9+ seems to be missing the 32-bit version (S8+ on the left, S9+ on the right)
 
 
 
 
Also posted this on StackOverflow.
 
Tags

renderscript , GPU , android

Post Reply
Board View
Newbie angelo.gallar**** , 210 Seed Apr 20, 2018 09:05 Post #1 0
Hi,
I'm experiencing the same kind of error.
Any update?
Post Reply
Board View
r.liechty_SDP , Jun 04, 2018 15:22 Post #2 0


This content has been quoted from angelo.gallarello’s thought.

Hi,
I’m experiencing the same kind of error.
Any update?

I apologize for how long this has taken to respond.  The bug causing this problem has been found and a fix should be public in in the second half of June.

Ron
Samsung Developer Program
Post Reply