Subscription preference

Notification emails are sent to your Samsung account email address.

* Email : anonymous@samsung.com

  

Close

Unable connect using sdboverbt

Forums View
Started by Newbie smartw**** , 140 Seed May 21, 2018 18:49 Replies : 22 View : 8417 Likes : 8
I'm unable to connect my watch to wifi. So i'm trying to use the sdboverbt. I'm on the latest version of GWD, i've installed sdboverbt on my phone. The watch is connected to the phone via usb, the phone is connected to the watch via bt. When i select my watch on the sdboverbt app, it says "cannot connect BT: Gear S3 (B851), please check SPP connection or BT pairing.

Any help would be appreciated.
Post Reply
Board View
r.liechty_SDP , May 21, 2018 21:56 Post #1 0
Usually you can just use your mobile device as WiFi for loading the GWD app.

Check this FAQ #14 https://developer.samsung.com/gear/design/watch-designer/faq if you have connections but can't connect.  

I don't think you can use SDB to load GWD watch faces but I'll watch this to see if anyone was successful and take note.

Ron
Post Reply
Board View
Developer sags**** , 9980 Seed May 21, 2018 23:21 Post #2 0
1.
IMHO this is running gag...
ADB and SDB... similar...
Sends same Commands

2.
sdb install
or
adb install

3.
BT related... but I was NEVER able to do this...
https://developer.samsung.com/gear/design/watch-designer/gear-watch-getting/connect

Why to go the long and hard way... if SDB is easy.


My opinion.

Best Regards







Post Reply
Board View
Samsung Developer j**** , 36420 Seed Sep 14, 2018 02:35 Post #3 0


This content has been quoted from r.liechty’s thought.

Usually you can just use your mobile device as WiFi for loading the GWD app.

Check this FAQ #14 https://developer.samsung.com/gear/design/watch-designer/faq if you have connections but can’t connect.  

I don’t think you can use SDB to load GWD watch faces but I’ll watch this to see if anyone was successful and take note.

Ron

Before GWD 1.6.0 I had no problems connecting watches to GWD via wifi. But after 1.6 , it takes multiple tries to get the watches to connect if I'm lucky. Most of the time it just refuse to connect to the watches. Out of desperation, I'm trying to do the SDB, but no luck.

I got as far as step 2 in this instruction https://developer.samsung.com/galaxy-watch/design/watch-designer/gear-watch-getting/connect
SDBoverBT didn't automatically installed as stated in the instruction. I installed it manually by transfering the sdboverbt_160523.apk from GWD folder on PC to Note8. After launch sdboverbt, I can see my watch list. But when I select one that's connected to the phone via BT. It states the following:

cannot connectBT:
Gear S3(C212), please check SPP connection or BT paring 
Socket: diable
Bluetooth: disable
SDB port:0, GDB port:0

S3 is connected to note8 via BT and I can see note8 listed in GWD's Run on Device panel, but no watch list selection...


Post Reply
Board View
Developer cosmicbre**** , 1170 Seed Sep 18, 2018 17:16 Post #4 1
When I see this error I turn the watch off then on again and then try to connect to SDBOVERBT again and that usually makes it work.  It will tell me that the watch is connected and then sometimes I need to unplug the USB from the phone and plug it back in again to get the "Connection Bridged" in the dialog box.

My problem is that even with that I see the phone show up in GWD but no amount of clicking on it will produce the watch to select.
Post Reply
Board View
Newbie cac38**** , 210 Seed Sep 19, 2018 15:01 Post #5 0


This content has been quoted from jshih’s thought.

 



This content has been quoted from r.liechty’s thought.

Usually you can just use your mobile device as WiFi for loading the GWD app.

Check this FAQ #14 https://developer.samsung.com/gear/design/watch-designer/faq if you have connections but can’t connect.  

I don’t think you can use SDB to load GWD watch faces but I’ll watch this to see if anyone was successful and take note.

Ron

Before GWD 1.6.0 I had no problems connecting watches to GWD via wifi. But after 1.6 , it takes multiple tries to get the watches to connect if I’m lucky. Most of the time it just refuse to connect to the watches. Out of desperation, I’m trying to do the SDB, but no luck.

I got as far as step 2 in this instruction https://developer.samsung.com/galaxy-watch/design/watch-designer/gear-watch-getting/connect
SDBoverBT didn’t automatically installed as stated in the instruction. I installed it manually by transfering the sdboverbt_160523.apk from GWD folder on PC to Note8. After launch sdboverbt, I can see my watch list. But when I select one that’s connected to the phone via BT. It states the following:

cannot connectBT:
Gear S3(C212), please check SPP connection or BT paring 
Socket: diable
Bluetooth: disable
SDB port:0, GDB port:0


S3 is connected to note8 via BT and I can see note8 listed in GWD’s Run on Device panel, but no watch list selection...


 

Getting the same picture as above.  Same respone with the sdboverbt.  Does this really work and if so what is the fix??  How about a method to transfer the GWD to the phone and  then the transfer to the watch would be easy!
Post Reply
Board View
Newbie stil2693 , 250 Seed Nov 23, 2018 10:46 Post #6 1
Everything's in recommended configuration, debug modes on as necessary, I've tried both methods numerous times, rebooted the watch no end of times held my breath and danced a jig by the light of the moon and nothing seems to bloody work kroger feedback.
Post Reply
Board View
Newbie mitier , 310 Seed Dec 21, 2018 23:27 Post #7 4
How to Connect your Galaxy Watch to Your Computer (Galaxy Watch Designer) and Upload a Watch Design via "Run on Device":

I had the same issues and was finally able to figure it out how to upload a watch face to my Galaxy Watch using my Note 9 connected to the Galaxy Watch via Bluetooth and my Note 9 connected to my computer via USB. There are quite a few hoops to jump through and this worked:
  1. On Computer: Download the Galaxy Watch Designer (https://developer.samsung.com/galaxy-watch/design/watch-designer).
  2. On Computer: Copy the sdboverbt_160523.apk file from the \\GearWatchDesigner\tizen\tools\ folder and paste it into your phone’s download folder (connect your phone to your computer via USB).
  3. On Phone: open the sdboverbt_160523.apk file from your downloads folder to install the application.
  4. On Phone: Turn on developer mode by going to Settings > About Phone > Software Information and then clicking on the “Build Number” until the developer options appear. (https://developer.samsung.com/galaxy-watch/design/watch-designer/gear-watch-getting/connect is a good resource for the following, but some steps are missing as seen below).
  5. On Phone: Turn on USB Debugging by going to Settings > Developer Options (at the bottom) and turn on “USB Debugging” (on my phone this was the 11th item and the 1st in the “Debugging” section).
  6. On Phone: restart phone.
  7. On Watch: Turn on debugging mode by going to Settings > About Watch and then turning on “Debugging”.
  8. On Watch: Turn on Developer Mode by going to Settings > About Watch > Software and then clicking on “Software Version” until the developer mode turns on
  9. On Watch: restart watch.
  10. On Phone: open the apk program (for me it would open automatically when I started the Galaxy Watch Designer) and select your watch as the one for debugging. If this works, Socket and Bluetooth will read “Enabled” and you will see an SDB port. This will work even if you did not turn the developer mode on on your watch, but you will not be able to upload your watch face until you do.
  11. On Computer: Now open the Galaxy Watch Designer and create a project and press F9 to upload it to your watch. You will have to make some keys and accounts, but this should hopefully be straightforward. In general, instead of pressing F9 you can click the “Run on Device” button towards the upper right hand corner of the Galaxy Watch Designer and it should show your phone, and under your phone show your watch. If it pops up with “No Device Found” and a debugging list then there is an issue and you should revisit the above steps.
Hope that works and let me know if I missed anything! I'm going by memory from what I did and may have left something out :)
Post Reply
Board View
Newbie Gilligan , 210 Seed Dec 26, 2018 04:42 Post #8 0
Mitier... this is working for you?

On my LG G4 the SDBoverBT app crashes as soon as I select that device for debugging.

I also can't find it over wifi so I'm lost.

I'm using a G2 watch.

Gilligan


This content has been quoted from mitier’s thought.

How to Connect your Galaxy Watch to Your Computer (Galaxy Watch Designer) and Upload a Watch Design via "Run on Device":

I had the same issues and was finally able to figure it out how to upload a watch face to my Galaxy Watch using my Note 9 connected to the Galaxy Watch via Bluetooth and my Note 9 connected to my computer via USB. There are quite a few hoops to jump through and this worked:

  1. On Computer: Download the Galaxy Watch Designer (https://developer.samsung.com/galaxy-watch/design/watch-designer).
  2. On Computer: Copy the sdboverbt_160523.apk file from the \\GearWatchDesigner\tizen\tools\ folder and paste it into your phone’s download folder (connect your phone to your computer via USB).
  3. On Phone: open the sdboverbt_160523.apk file from your downloads folder to install the application.
  4. On Phone: Turn on developer mode by going to Settings > About Phone > Software Information and then clicking on the “Build Number” until the developer options appear. (https://developer.samsung.com/galaxy-watch/design/watch-designer/gear-watch-getting/connect is a good resource for the following, but some steps are missing as seen below).
  5. On Phone: Turn on USB Debugging by going to Settings > Developer Options (at the bottom) and turn on “USB Debugging” (on my phone this was the 11th item and the 1st in the “Debugging” section).
  6. On Phone: restart phone.
  7. On Watch: Turn on debugging mode by going to Settings > About Watch and then turning on “Debugging”.
  8. On Watch: Turn on Developer Mode by going to Settings > About Watch > Software and then clicking on “Software Version” until the developer mode turns on
  9. On Watch: restart watch.
  10. On Phone: open the apk program (for me it would open automatically when I started the Galaxy Watch Designer) and select your watch as the one for debugging. If this works, Socket and Bluetooth will read “Enabled” and you will see an SDB port. This will work even if you did not turn the developer mode on on your watch, but you will not be able to upload your watch face until you do.
  11. On Computer: Now open the Galaxy Watch Designer and create a project and press F9 to upload it to your watch. You will have to make some keys and accounts, but this should hopefully be straightforward. In general, instead of pressing F9 you can click the “Run on Device” button towards the upper right hand corner of the Galaxy Watch Designer and it should show your phone, and under your phone show your watch. If it pops up with “No Device Found” and a debugging list then there is an issue and you should revisit the above steps.
Hope that works and let me know if I missed anything! I’m going by memory from what I did and may have left something out :)

 

Post Reply
Board View
Newbie nothingtoseehere , 230 Seed Feb 28, 2019 23:18 Post #9 1
This didn't work. I tried many times


This content has been quoted from mitier’s thought.

How to Connect your Galaxy Watch to Your Computer (Galaxy Watch Designer) and Upload a Watch Design via "Run on Device":

I had the same issues and was finally able to figure it out how to upload a watch face to my Galaxy Watch using my Note 9 connected to the Galaxy Watch via Bluetooth and my Note 9 connected to my computer via USB. There are quite a few hoops to jump through and this worked:

  1. On Computer: Download the Galaxy Watch Designer (https://developer.samsung.com/galaxy-watch/design/watch-designer).
  2. On Computer: Copy the sdboverbt_160523.apk file from the \\GearWatchDesigner\tizen\tools\ folder and paste it into your phone’s download folder (connect your phone to your computer via USB).
  3. On Phone: open the sdboverbt_160523.apk file from your downloads folder to install the application.
  4. On Phone: Turn on developer mode by going to Settings > About Phone > Software Information and then clicking on the “Build Number” until the developer options appear. (https://developer.samsung.com/galaxy-watch/design/watch-designer/gear-watch-getting/connect is a good resource for the following, but some steps are missing as seen below).
  5. On Phone: Turn on USB Debugging by going to Settings > Developer Options (at the bottom) and turn on “USB Debugging” (on my phone this was the 11th item and the 1st in the “Debugging” section).
  6. On Phone: restart phone.
  7. On Watch: Turn on debugging mode by going to Settings > About Watch and then turning on “Debugging”.
  8. On Watch: Turn on Developer Mode by going to Settings > About Watch > Software and then clicking on “Software Version” until the developer mode turns on
  9. On Watch: restart watch.
  10. On Phone: open the apk program (for me it would open automatically when I started the Galaxy Watch Designer) and select your watch as the one for debugging. If this works, Socket and Bluetooth will read “Enabled” and you will see an SDB port. This will work even if you did not turn the developer mode on on your watch, but you will not be able to upload your watch face until you do.
  11. On Computer: Now open the Galaxy Watch Designer and create a project and press F9 to upload it to your watch. You will have to make some keys and accounts, but this should hopefully be straightforward. In general, instead of pressing F9 you can click the “Run on Device” button towards the upper right hand corner of the Galaxy Watch Designer and it should show your phone, and under your phone show your watch. If it pops up with “No Device Found” and a debugging list then there is an issue and you should revisit the above steps.
Hope that works and let me know if I missed anything! I’m going by memory from what I did and may have left something out :)

 



Post Reply
Board View
Newbie capr0658 , 390 Seed Jun 13, 2019 04:58 Post #10 0
What is sdbeoverbt? Please suggest me how to do this ? How can i connect for my site.

Post Reply
Board View
r.liechty_SDP , Jun 18, 2019 21:43 Post #11 0


This content has been quoted from capr0658’s thought.

What is sdbeoverbt? Please suggest me how to do this ? How can i connect for my site.
 

Samsung Debugging over BlueTooth.  You can't connect to your site. it is for connecting your computer to your phone to then to your watch fot install and update watch apps

Ron
Samsung Developer Program
Post Reply
Board View
Newbie nicksgara**** , 730 Seed Jul 20, 2019 02:22 Post #12 0
I used to be able to connect my watches to GWD over wifi but no luck lately. I'm now using my Galaxy S10+ connected via USB. The key for me is to reboot the watch after doing all the steps to connect. Then I can generate the certificate if needed and then upload the watch face to the watch.
Post Reply
Board View
Newbie tomnat , 790 Seed Aug 29, 2019 16:03 Post #13 0
Mitier, this method worked about 3/4 of the way for me. I followed all the steps, and once the sdboverbt app found my watch it listed bluetooth enabled, but the socket was disabled. Might there be one thing that was left out of the procedure, or perhaps someone has an idea of how to get the socket enabled? Thanks.
Post Reply
Board View
Newbie tomnat , 790 Seed Aug 30, 2019 19:30 Post #14 0


This content has been quoted from tomnat’s thought.

Mitier, this method worked about 3/4 of the way for me. I followed all the steps, and once the sdboverbt app found my watch it listed bluetooth enabled, but the socket was disabled. Might there be one thing that was left out of the procedure, or perhaps someone has an idea of how to get the socket enabled? Thanks.

Well, I think I figured it out or stumbled upon it really. I have a Galaxy s8 and nowhere did I read that you need to have the Android USB drivber for Windows. I don't know much about these things, but I concluded that within the SDBoverBT app, the "bluetooth enabled" refered to the connection with the watch, while the "socket disabled" was referring to the phones connection with my PC. I thought that perhaps the USB cable I was using may be the issue, so I switched cables and nothing changed. I then looked at the USB connection options on my phone and decided to try the MIDI option. It didn't work either, but it did put up a window on my PC showing me three items, two of which had a greeen check mark and the third one that said something like, "ADB interface driver", had a red X. I then searched for Galaxy S8 ADB interface driver and it was right there........on this site; Android USB driver for Windows. I downloaded it, ran the app again, and lo and behold it worked! Both socket and bluetooth were enabled. I haven't progressed further than that, but the GWD prgram finally recognized my phone. I hope this helps a little.
Post Reply
Board View
Newbie tomnat , 790 Seed Sep 03, 2019 17:41 Post #15 0
ok, I seem to be stuck again as I fumble my way through this. I got Galaxy Watch Designer to see my phone, however, from what I have read, my watch should be listed underneath my phone and it is not. The SDBoverBT app shows that both the socket and bluetooth are enabled, so I am just not sure what else to do. I am starting to wonder if the GWD program is even compatible with my watch. Seems ludicrous because my watch is a Galaxy Watch that I bought about 2 weeks ago, so it should have no issues, but what do I know; like I said, I am just fumbling through this. If anyone has an idea, I am all ears. Thanks.
Post Reply
Board View
r.liechty_SDP , Sep 05, 2019 00:00 Post #16 0


This content has been quoted from tomnat’s thought.

ok, I seem to be stuck again as I fumble my way through this. I got Galaxy Watch Designer to see my phone, however, from what I have read, my watch should be listed underneath my phone and it is not. The SDBoverBT app shows that both the socket and bluetooth are enabled, so I am just not sure what else to do. I am starting to wonder if the GWD program is even compatible with my watch. Seems ludicrous because my watch is a Galaxy Watch that I bought about 2 weeks ago, so it should have no issues, but what do I know; like I said, I am just fumbling through this. If anyone has an idea, I am all ears. Thanks.

I wish you had open a new thread this was hard to find.
I believe you've done all the yellow highlighted bits but make sure Debugging is on just runing developer options on in the software doesn't turn debugging on.

Here are a couple of tricks if the phone doesn't show it all hinges on allowing permissions.
Disconnect the USB from Phone
Turn off phone 
Turn Debugging off on Watch
Restart watch
Turn debugging back on... it will ask you to allow a permission. Do so and click don't ask again.  If you miss this step it goes by fast you can't run on device
restart watch again
Turn phone back on
launch SDBoverBT and connect to the phone  it will say Bluetooth enabled socket disabled
Connect phone to USB cable (allow data trasfer)
launch GWD if not running and select Run on Device
it should run fine now
start a new thread if that doesn't help this forum doesn't update old threads to new.

Ron
Samsung Developer Program

Go to Settings -> Gear info -> About device.
Tap on Software version 5 times. Then a confirmation pop up displayed once the Developer options is enabled.
Make sure Debugging is on in About Watch settings
Restart your watch

Connect your phone to your computer.
Allow Data Access
On the phone make sure USB debugging is enabled in the Developer Options

From the \program files\Galaxy Watch Designer\Tizen\Tools\
copy sdboverbt_160523.apk to your phone and install it.



In older versions of Windows you may need the Android USB Drive for Windows on youfPC from here. https://developer.samsung.com/galaxy/others/android-usb-driver-for-windows

Make sure debugging is enable for both your watch and phone

On the phone enable USB debugging in the developer Options

Launch SDBoverBT on your phone and connect to your watch

It will ask you to select your device it will show your watch click on it and it will be connected
You will have to agree to it the first time and it doesn't show very long so be sure you have your watch handy and running when you do that.

Once you are connected plug your phone into your computer and allow data transfer on your phone
launch GWD and from your project chose run on device
It will start the scan and then it will show the SDBoverBT icon

You may have to agree to another permission on my watch one more time.

The little timer will keep on spinning on the run on device window as if it was searching. Click on your phone and it will connect.



Post Reply
Board View
Newbie sara3033 , 220 Seed Sep 06, 2019 11:35 Post #17 0
Everything's in prescribed setup, investigate modes on as essential, I've attempted the two strategies various occasions, rebooted the watch no closure of times held my breath and moved a dance by the light of the moon and nothing appears to work except this https://www.customersurvey.us/gclistens/
Post Reply
Board View
r.liechty_SDP , Sep 06, 2019 15:23 Post #18 0


This content has been quoted from sara3033’s thought.

Everything’s in prescribed setup, investigate modes on as essential, I’ve attempted the two strategies various occasions, rebooted the watch no closure of times held my breath and moved a dance by the light of the moon and nothing appears to work except this Gclistens

There are several things that this can be and you'll probably slap your forehead when you figure it ou.

You are not allowing data transfer from your phone to computer when you plug in the USB cable. 
You do not have USB debugging on in the phone's developer Options
Most likely and this one got me...
You do not have permission for data transfer allowed to the device
To fix this turn off USB debugging turn and off  Developer Options
Restart the watch
I don't remember which of these steps ask for a permission. you need to allow it and then check don't ask again.  I hit deny and don't ask again and was where you were it does not stay on very long watch your watch closely.

turn on developer options
Turn on Debugging
The permission should appear allow it and don't ask again
Restart your watch
Restart your phone (it remembers it couldn't connect before)

Launch SDBoverbt and select the device
You shoull see the first image sdboverbt_sockect_disabled.png  
plug in your usb cable and start GWD
Select Run on Device  
You should see socket enabled.png
it should start a scan and then pop up your watch sdb over bluetooth 2.png

If this doesn't work or doesn't show up You probably will need to contact support and give them your system information.  

Ron
Samsung Developer Program

File Attachments
Post Reply
Board View
Newbie Spazmier , 240 Seed Oct 07, 2019 23:05 Post #19 1
I have followed all of the suggestions listed here...and I am ever so close!  sdboverbt lists Socket and Bluetooth both enabled, and I see an SDB port # and a GDB port #.  In GWD, I select "Run on Device", and a small window opens "Connected Watch".  I see my phone, but no sub-item.  If I understand correctly, I should see my watch as a sub-item to my phone, and I should be able to click on it to initiate the transfer.  Any suggestions?  (Phone: OnePlus 5T Watch: Galaxy Watch Active)
Post Reply
Board View
r.liechty_SDP , Oct 08, 2019 14:38 Post #20 0


This content has been quoted from Spazmier’s thought.

I have followed all of the suggestions listed here...and I am ever so close!  sdboverbt lists Socket and Bluetooth both enabled, and I see an SDB port # and a GDB port #.  In GWD, I select "Run on Device", and a small window opens "Connected Watch".  I see my phone, but no sub-item.  If I understand correctly, I should see my watch as a sub-item to my phone, and I should be able to click on it to initiate the transfer.  Any suggestions?  (Phone: OnePlus 5T Watch: Galaxy Watch Active)

If you see the watch in the SDBoverBT app then it is likely you didn't allow file transfer from your computer to the phone. On my Windows machine I had to allow it one time on my work computer  but not personal computer. On the phone I have to allow it everytime I connect and it goes away quickly so unplug the USB cable and reconnect to be sure it is approved.   If that isn't it check your phone's settings and be sure that developer options are enabled and that the debug over USB is enabled.

Ron
Samsung Developer Program
Post Reply
Board View
Newbie just5395 , 220 Seed Oct 13, 2019 02:05 Post #21 0


This content has been quoted from Spazmier’s thought.

I have followed all of the suggestions listed here...and I am ever so close!  sdboverbt lists Socket and Bluetooth both enabled, and I see an SDB port # and a GDB port #.  In GWD, I select "Run on Device", and a small window opens "Connected Watch".  I see my phone, but no sub-item.  If I understand correctly, I should see my watch as a sub-item to my phone, and I should be able to click on it to initiate the transfer.  Any suggestions?  (Phone: OnePlus 5T Watch: Galaxy Watch Active)

I am having the exact same problem. The only difference is that I'm using the S8, which probably doesn't matter. 
I would love to hear a solution as well. Thanks.
Post Reply
Board View
r.liechty_SDP , Oct 14, 2019 15:03 Post #22 0


This content has been quoted from just5395’s thought.

 



This content has been quoted from Spazmier’s thought.

I have followed all of the suggestions listed here...and I am ever so close!  sdboverbt lists Socket and Bluetooth both enabled, and I see an SDB port # and a GDB port #.  In GWD, I select "Run on Device", and a small window opens "Connected Watch".  I see my phone, but no sub-item.  If I understand correctly, I should see my watch as a sub-item to my phone, and I should be able to click on it to initiate the transfer.  Any suggestions?  (Phone: OnePlus 5T Watch: Galaxy Watch Active)

I am having the exact same problem. The only difference is that I’m using the S8, which probably doesn’t matter. 
I would love to hear a solution as well. Thanks.

 

Unplug the USB port plug it back in be sure to allow file transfer permission this does not last very long.
One time I had to allow it oon my PC too, not sure why it only happened one time.

If you see what I have in the connections but the watch doesn't show up, it is a permissions that was not OK'd  Start over.

I guarantee once it connects you'll wonder why it didn't always work.

Ron
Samsung Developer Program
Post Reply