Subscription preference

Notification emails are sent to your Samsung account email address.

* Email : anonymous@samsung.com

  

Close

TPK not valid

Forums View
Started by Newbie vaish**** , 760 Seed Jan 31, 2019 05:47 Replies : 6 View : 1037 Likes : 0
Its been a while since I placed with the Galaxy Watch Designer. After updating GWD to v.1.6.2 and corresponding JRE versions I finally got it to a point where I can open my year old projects.
But.. it looks like I can no longer push a tpk to my Gear Fit 2 (SM-R360 r360xxu1erc7). My distribution certificate seems to be functioning fine, and "Run on Device" seems to be recreating the tpk and pushing it to the device. At about 61% I get this error. I have no idea how to proceed further. Re-installing GWD, Tizen Studio, JRE and JDK all seem to have the same result. What am I missing?

 

Post Reply
Board View
r.liechty_SDP , Jan 31, 2019 16:30 Post #1 0
I hope you backed up your .gwd files before opening them with 1.6.2  if not do that for any other projects that you have in case you need to go back to an older version of GWD.

Having said that I haven't heard of anyone else having a problem rebuilding Fit 2 projects. However there was a software update this past year and if you haven't built any thing in a year that could be a reason for the .tpk not working if that update hasn't been applied

I would delete the .tpk from your workspace restart your computer to get rid of any caches and rebuild.  If that doesn't work check to see if you have the latest OS for your Fit 2.

I don't think there is any improvements for Fit 2 in GWD 1.6.x so you may want to go back to a previous version.  You can click on the down arrow for downloading GWD to get the archives for the older versions of Gear Watch Designer.

Ron Liechty
Samsung Developer Program
Post Reply
Board View
Newbie vaish**** , 760 Seed Jan 31, 2019 17:43 Post #2 0
Thank you for the reply.
I did try creating a brand new project on the new version to see if that helped, but it too had the same issue. I'll try downgrading my GWD to see if that helps and report back.

Post Reply
Board View
Newbie milo0730 , 220 Seed Feb 01, 2019 07:23 Post #3 0
I have not touched the tizen-manifest.xml in the whole process so it is the default one generated by the IDE, yet pkgcmd is complaining it is not a valid one shareit.
Post Reply
Board View
Newbie vaish**** , 760 Seed Feb 01, 2019 16:10 Post #4 0
So... after multiple uninstalls/re-installs. I decided to try the set up on a different Windows 10 laptop I have. And it seems to have NO issues there in building my older gwd files, and pushing them to a device. So whatever the problem is, its with any lingering setiup on my original laptop. Any tips to where to go and clean up things? Registry? preference location?
Using the second laptop as my primary work location is not feasible unfortunately. 
Post Reply
Board View
r.liechty_SDP , Feb 01, 2019 17:30 Post #5 0


This content has been quoted from vaish****’s thought.

So... after multiple uninstalls/re-installs. I decided to try the set up on a different Windows 10 laptop I have. And it seems to have NO issues there in building my older gwd files, and pushing them to a device. So whatever the problem is, its with any lingering setiup on my original laptop. Any tips to where to go and clean up things? Registry? preference location?
Using the second laptop as my primary work location is not feasible unfortunately. 

I assume you have all your .gwd files backed up now.  I'd totally remove the user\gearwatchdesigner\workspace folder and restart the computer
copy your backup .gwd files to the workspace and see if that doesn't fix it.  Removing all the .tpks and such may solve it.

Let me know if that does or doesn't work I'll see how to generate a log to give more details.

Ron
Post Reply
Board View
Newbie vaish**** , 760 Seed Feb 15, 2019 18:26 Post #6 0


This content has been quoted from r.liechty_SDP’s thought.

 



This content has been quoted from vaish****’s thought.

So... after multiple uninstalls/re-installs. I decided to try the set up on a different Windows 10 laptop I have. And it seems to have NO issues there in building my older gwd files, and pushing them to a device. So whatever the problem is, its with any lingering setiup on my original laptop. Any tips to where to go and clean up things? Registry? preference location?
Using the second laptop as my primary work location is not feasible unfortunately. 

I assume you have all your .gwd files backed up now.  I’d totally remove the user\gearwatchdesigner\workspace folder and restart the computer
copy your backup .gwd files to the workspace and see if that doesn’t fix it.  Removing all the .tpks and such may solve it.

Let me know if that does or doesn’t work I’ll see how to generate a log to give more details.

Ron

 


Sorry about the delay in responding.Thank you so much for your help. Deleting the whole GearWatchDesigner folder did the trick! I am able to build and push tpks to my watch again

Post Reply