Subscription preference

Notification emails are sent to your Samsung account email address.

* Email : anonymous@samsung.com

  

Close

Gear Watch Designer Run Emulator runs too slow

Forums View
Started by Developer zah700 , 1410 Seed Jan 13, 2018 19:35 Replies : 7 View : 617 Likes : 4
Hi.

The Run emulator in Gear Watch Designer runs at 15fps, which does not give a true representation of moving elements on the watch, like the sweeping hand. This is not helpful when building watch faces. Is it possible to increase this to 30fps?

Thanks.



 
Post Reply
Board View
Samsung Developer drazen , 49420 Seed Jan 14, 2018 12:28 Post #1 1
It runs 15 FPS because that's what the watch runs at. Screen has a 15 fps refresh rate, animations run at 15 fps etc. 

But, you are right about one thing - the preview window does run slow - even slower than 15 fps. It is very sluggish. I have noticed this few months ago and tried to see with dev team what could be causing this, but never really got much feedback. What I did notice is that once I open the Run window, only one of my processor cores goes to 100% use, while 7 others are at idle. Can you check if you have the same results?


Post Reply
Board View
Developer zah700 , 1410 Seed Jan 14, 2018 15:34 Post #2 1
I guess you are correct, however, what I observe on the Run window and on the watch itself are different speeds. Therefore, I have come to the conclusion that the Run emulator is running slower than a normal video rate would be. Also, I have observed that there is a 6 fold increase in processor usage when I call up the Run Window, so it's pretty heavy on cpu usage. Memory does not appear to be affected though. 

As a test, I tried to record one of my watch faces from the Run window and when I played it back, from the sweeping hand movement,  it is obviously running slower than a nornal video would show the same movement. I think a normal fps for video is around 24-25 fps.



This content has been quoted from drazen’s thought.

It runs 15 FPS because that’s what the watch runs at. Screen has a 15 fps refresh rate, animations run at 15 fps etc. 

But, you are right about one thing - the preview window does run slow - even slower than 15 fps. It is very sluggish. I have noticed this few months ago and tried to see with dev team what could be causing this, but never really got much feedback. What I did notice is that once I open the Run window, only one of my processor cores goes to 100% use, while 7 others are at idle. Can you check if you have the same results?

 


Post Reply
Board View
Developer zah700 , 1410 Seed Jan 14, 2018 15:44 Post #3 1
On the matter of your core processors, are you utilising all the processors? I saw a youtube video that explained why manufacturers do not envoke all processors on the chip, and when I checked, it was correct. Only one core was active. I have since changed the configuration on my laptop so that all cores are active now, and it has speeded up my daily usage quite a bit.


This content has been quoted from drazen’s thought.

It runs 15 FPS because that’s what the watch runs at. Screen has a 15 fps refresh rate, animations run at 15 fps etc. 

But, you are right about one thing - the preview window does run slow - even slower than 15 fps. It is very sluggish. I have noticed this few months ago and tried to see with dev team what could be causing this, but never really got much feedback. What I did notice is that once I open the Run window, only one of my processor cores goes to 100% use, while 7 others are at idle. Can you check if you have the same results?

 


Post Reply
Board View
Samsung Developer drazen , 49420 Seed Jan 15, 2018 00:31 Post #4 1

This content has been quoted from zah700’s thought.

 

I guess you are correct, however, what I observe on the Run window and on the watch itself are different speeds. Therefore, I have come to the conclusion that the Run emulator is running slower than a normal video rate would be. Also, I have observed that there is a 6 fold increase in processor usage when I call up the Run Window, so it’s pretty heavy on cpu usage. Memory does not appear to be affected though. 

As a test, I tried to record one of my watch faces from the Run window and when I played it back, from the sweeping hand movement,  it is obviously running slower than a nornal video would show the same movement. I think a normal fps for video is around 24-25 fps.

 

The frame rate is basically irrelevant (it's really 15 fps, trust me) - the real problem is that the Run window in GWD has been running slow / laggy for months now. Strangely enough, it was perfectly fine in GWD 1.3.2. I know that for a fact because I often screen-recorded the Run window and used the captured video to show the watchface in action on Youtube. There were absolutely no issues at all. But when new version of GWD came out, I immediately noticed that the Run window was not playing back smoothly. 

In 1.4 versions it was SUPER slow. Now with 1.5 it's slightly better, but still no where near the old performance. And the 1 processor core still stays locked on full load, while the rest of them just sit and do nothing.

As for the configurations, I don't see that there's anything special to set up on my workstation that would magically make GWD use more than one core. I have a dual Xeon processor workstation, with 48 gigs of ram, SSD's, Quadro card etc. I can edit 4K videos on it, but somehow I can't play back a 512x512 simple animation at 15 fps? That really makes no sense.

Post Reply
Board View
Developer zah700 , 1410 Seed Jan 15, 2018 12:05 Post #5 0
Okay, thanks for the further clarifications.
On the other matter of core processors, if you are on Windows 10, then you could check by doing the following:
in RUN, type msconfig
select the Boot Tab
select Advanced options
see the number of processors it shows. If it show 1, then you system is not utilising all your processor capacity.
You can watch the following video and decide if you want to change your own configuration:
Double Your Computer CPU Speed for Free (from ThioJoe)

https://www.youtube.com/watch?v=8unagKHPGt8


This content has been quoted from drazen’s thought.

 


This content has been quoted from zah700’s thought.

 

I guess you are correct, however, what I observe on the Run window and on the watch itself are different speeds. Therefore, I have come to the conclusion that the Run emulator is running slower than a normal video rate would be. Also, I have observed that there is a 6 fold increase in processor usage when I call up the Run Window, so it’s pretty heavy on cpu usage. Memory does not appear to be affected though. 

As a test, I tried to record one of my watch faces from the Run window and when I played it back, from the sweeping hand movement,  it is obviously running slower than a nornal video would show the same movement. I think a normal fps for video is around 24-25 fps.

 

The frame rate is basically irrelevant (it’s really 15 fps, trust me) - the real problem is that the Run window in GWD has been running slow / laggy for months now. Strangely enough, it was perfectly fine in GWD 1.3.2. I know that for a fact because I often screen-recorded the Run window and used the captured video to show the watchface in action on Youtube. There were absolutely no issues at all. But when new version of GWD came out, I immediately noticed that the Run window was not playing back smoothly. 

In 1.4 versions it was SUPER slow. Now with 1.5 it’s slightly better, but still no where near the old performance. And the 1 processor core still stays locked on full load, while the rest of them just sit and do nothing.

As for the configurations, I don’t see that there’s anything special to set up on my workstation that would magically make GWD use more than one core. I have a dual Xeon processor workstation, with 48 gigs of ram, SSD’s, Quadro card etc. I can edit 4K videos on it, but somehow I can’t play back a 512x512 simple animation at 15 fps? That really makes no sense.

 


Post Reply
Board View
Samsung Developer petruuccios , 41700 Seed Jan 15, 2018 13:27 Post #6 0
Try to put there blank black image, just empty watchface to see the difference in CPU load. 
My first impression was, the preview will load the CPU same, as no matter how complicated content. But there is a visible change, when there are hands.

This remotely reminds me the Flash on webpages. 
Any webpage containing Flash components whether video, or animation, or banners, or what not, has one thing in common. It uses 100% of available CPU resources.
Since it can't use more than 1 core, my CPU says its 25% used. I'm glad, that it can't use more than one core, else it would make my PC unresponsive.


Post Reply
Board View
Samsung Developer drazen , 49420 Seed Jan 16, 2018 01:22 Post #7 0


This content has been quoted from petruuccios’s thought.

Try to put there blank black image, just empty watchface to see the difference in CPU load. 
My first impression was, the preview will load the CPU same, as no matter how complicated content. But there is a visible change, when there are hands.

This remotely reminds me the Flash on webpages. 
Any webpage containing Flash components whether video, or animation, or banners, or what not, has one thing in common. It uses 100% of available CPU resources.
Since it can’t use more than 1 core, my CPU says its 25% used. I’m glad, that it can’t use more than one core, else it would make my PC unresponsive.
 

Yep I know, I did my own tests as well but there's still an obvious issue here. 

GWD simply should not be using that much processing power. I mean come on, we're dealing with 512x512 emulator, running mostly 360x360 graphics at rediculously low fps. Even my most complex watchfaces are under 20 megabytes, that's literally nothing for todays machines and should really be no challenge for my workstation. If I can run After Effects with 100+ layers and dozens of effects, have Photoshop and Corel open, a web browser running videos and whatnot all without any issues, it's hard to believe something this simple can drag the performance down so much.

As for the msconfig, all of my 12 processors are active. I even tried enabling hyperthreading in system bios to get 24 processors registered. Doesn't make any difference at all. Which doesn't surprise me, because this doesn't have anything to do with processors. It's some sort of an programming error in GWD. Even a 32 bit app will  use multiple cores, but for some reason GWD likes that 1 core and loves keeping it at 100%.


Post Reply