Subscription preference

Notification emails are sent to your Samsung account email address.

* Email : anonymous@samsung.com

  

Close

Watch face flicker

Forums View
Started by Expert Developer malcolmpe , 16720 Seed Feb 28, 2018 02:04 Replies : 6 View : 593 Likes : 0
Made a trial watch face with bmp fonts saved it installed it , just wont load Flickers 3 times and goes back to the default face

malcolmpe choose r.liechty ’s reply as the Best Answer. r.liechty earned +250 SEED. Mar 01, 2018 00:09
Tags

watchfaceflicker

Post Reply
Board View
Samsung Developer s.arefin , 38030 Seed Feb 28, 2018 05:34 Post #1 0
can you share in images, so that someone can share their ideas. also mention the version and related information for more understanding.
Post Reply
Board View
Developer hennet.nailo , 9330 Seed Feb 28, 2018 20:03 Post #2 0
have the same issue, did you figure out what's the problem?
Post Reply
Board View
r.liechty , Feb 28, 2018 21:07 Post #3 0


This content has been quoted from hennet.nailo’s thought.

have the same issue, did you figure out what’s the problem?

 

I've gotten other reports of this.

I'm sending it to the development team to see what they say.

Ron
Post Reply
Board View
Expert Developer malcolmpe , 16720 Seed Mar 01, 2018 00:09 Post #4 0


This content has been quoted from r.liechty’s thought.

 



This content has been quoted from hennet.nailo’s thought.

have the same issue, did you figure out what’s the problem?

 

I’ve gotten other reports of this.

I’m sending it to the development team to see what they say.

Ron

 

Just made a new watch face which loaded good , but the old ones are still are a problem, will keep trying though

just read another post about the flickering watch face i think I know what is causing it.

I built a new watch face which is working fine . it has a default Aod I think if I do it with a proper custom Aod it will fail

I will get back to you soon.
I was wrong the custom Aod works .!!!!

Post Reply
Board View
Expert Developer malcolmpe , 16720 Seed Mar 11, 2018 03:39 Post #5 0


This content has been quoted from malcolmpe’s thought.

 



This content has been quoted from r.liechty’s thought.

 



This content has been quoted from hennet.nailo’s thought.

have the same issue, did you figure out what’s the problem?

 

I’ve gotten other reports of this.

I’m sending it to the development team to see what they say.

Ron

 

Just made a new watch face which loaded good , but the old ones are still are a problem, will keep trying though

just read another post about the flickering watch face i think I know what is causing it.

I built a new watch face which is working fine . it has a default Aod I think if I do it with a proper custom Aod it will fail

I will get back to you soon.
I was wrong the custom Aod works .!!!!

 

Hey Ron I am still having problems with bitmap fonts watch faces only for the week days where a dash or ia image moves rom one digital clock to another, the wace flickers 3 times andgoes back to the stock face, the anomally is it loads on my girl friens S2 with asamsung phone but does not load on the S# both classic and frontier with the pixel phone.Need some solutions. I might have to buy a smasung phone but on the flip sie it is not good for samsung if it does not work good with other android phones . I don't know what to do

Post Reply
Board View
r.liechty , Mar 28, 2018 14:14 Post #6 0
I posted this on another thread but will also post here because it seems to be common,

This technically is not a GWD issue but needs a firmware update to fix. However there is a workaround,

The Cause :

         In the device, text string converted to bitmap font set which matched with each character. But crash happens if all text characters have no matched bitmap at all.

         For example, if developer added bitmap only for ‘1’ ~ ‘9’ (without ‘0’), and text string in the device composed of all ‘0’s (like 00:00:00’) then crash happens.

         
The Solution :

         Added dummy character ‘\u200B’(zero width space character) for each text string to avoid null bitmap set issue.

This will work on both new and old firmware.

Ron
Post Reply